Heinz

TP-Link MR200 dodane do LEDE

24 posts in this topic

Hi :)

 

I have upgrade "lede-ramips-mt7620-ArcherMR200-squashfs-sysupgrade.bin" based on your google drive (mr200.zip) firmware from Luci web firmware sysupgrade but now i can only putty the MR200 to the default IP "192.168.1.1" (all stuff are gone and the settings) no more httpd / adb / LTE/4G / LuciWeb etc. :(:(:( and only power and lan led up.

Are you able to help me ?

 

I have asked also in openwrt forum thread, so we can continue there (i trying here because i didn't notice notification on openWRT forum).

I hope you can help me.

Big thanks in advance.

 

Attached is my second attempt log to flash "lede-ramips-mt7620-ArcherMR200-squashfs-sysupgrade.bin" from putty connection. Still seems an kind of empty firmware :(

log_sysupgrade.txt

Edited by Sebastiii
0

Share this post


Link to post
Share on other sites

Hi.

This is official LEDE snapshot and doesn have LuCI interface.

 

7 godzin temu, Sebastiii napisał:

Still seems an kind of empty firmware :(

I know about this. I fix it yesterday and today fix is accepted by LEDE: https://git.lede-project.org/?p=source.git;a=commit;h=4f033b2da67f666a98cce267c2426fb532c90590

Wait to buildbot bulding new image. 

 

When You install new fixed image You can login to modem and set 3G/LTE conneciton and login to ssh to router and instal Luci using command:

opkg update

opkg install luci

0

Share this post


Link to post
Share on other sites

Hi :)

 

Ah that's a good news, i was too speedy, when buildbot build new images ? (i can surely look at the timestamp of the linked file, it's seems to do it around 22H30).

So for now i have restored your 'ArcherC2V1_tp_recovery.bin' with TFTP to have the router working again.

 

But can you confirm me that next builded image from buildbot will be up gradable over your version ?

Thanks again.

 

0

Share this post


Link to post
Share on other sites
3 minuty temu, Sebastiii napisał:

But can you confirm me that next builded image from buildbot will be up gradable over your version ?

 

This is official LEDE build not my, but with my changes. New firmware is upgradable from previous LEDE.

Wait ~5 min Buildbot is now running.

 

0

Share this post


Link to post
Share on other sites

Great :)

Let's try then

Thanks i will report back here :)

I'm getting a red message :)

Flash Firmware - Verify

The flash image was uploaded. Below is the checksum and file size listed, compare them with the original file to ensure data integrity.
Click "Proceed" below to start the flash procedure. 
 

It appears that you are trying to flash an image that does not fit into the flash memory, please verify the image file!

 

  • Checksum
    MD5: 9152d22ca3f7c1b99bcd7663dbfd556a
    SHA256: af185519b17e041cb6bf8cdf6cfaabea0b76abd08703f972c76e25ccb3c0cbad
  • Size: 7.69 MB (7.69 MB available)
  • Configuration files will be kept.

 

 

0

Share this post


Link to post
Share on other sites

This message appears because firmware have "metadata" at end of file. Do not worry about it, metadata is not writen to flash.

0

Share this post


Link to post
Share on other sites

Thanks :)

 

So i have flashed it (internet was working and i have reinstalled luci like you explain me) and i have restored a bakcup config and it solve the issue i was getting about privoxy :)

The interface has changed and i like the new one :P

 

It's seems that i can't install 3ginfo :

 

root@lede:~# opkg install http://dl.eko.one.pl/chaos_calmer/ramips/packages/3ginfo-text_20161111_all.ipk
Downloading http://dl.eko.one.pl/chaos_calmer/ramips/packages/3ginfo-text_20161111_all.ipk.
Installing 3ginfo-text (20161111) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for 3ginfo-text:
 *      comgt *
 * opkg_install_cmd: Cannot install package 3ginfo-text.

 

maybe it's needed to have an update ? :)

 

I'm testing it to see if all works like before.

Big thanks.

All is working, thanks again for your help, just need 3ginfo back and it would be perfect :P

Merry xmas :)

0

Share this post


Link to post
Share on other sites

There is strange thing i'm getting but no clue where it comes from.

The SIM is not detected after a while and i need to remove and put in back and it's up.

I think it was nothing to do about LEDE but more on android 4G card right ?

 

Edit : about SIM issue it seems to be my fault (testing IMEI while both connected to network) let see if it continue to works :)

Edited by Sebastiii
0

Share this post


Link to post
Share on other sites

Strange i can't edit my previous post, i forgot to write that it is not related to a double IMEI and that issue is always present but no clue why lol.

0

Share this post


Link to post
Share on other sites

Did You check this issue with another sim card?

0

Share this post


Link to post
Share on other sites

I have only one sim card and when using it on my phone i didn't run into this issue so i'm not sure it's related to the sim itself.

It happen randomly but seems more frequent when heaving data traffic is running but that just an impression :P

0

Share this post


Link to post
Share on other sites

Hi,

 

I have try xl2tpd and setup connection on lan but seems that i have mr200 limit reach and can't get all bandwitdh lol. So xl2tpd use CPU too much.

Also for now after the official upgrade and switched back to lede again( so android board was updated) i didn't run into the sim card issue (that's good) i hope it will stay like this :P

1

Share this post


Link to post
Share on other sites

Finally it just happened :(

 

Connection Status
Connection Status:Disconnected
SIM Card Status:Not found
IPv4 Address:0.0.0.0

 

To maybe to detectable again, i just need to remove and reinsert the SIM card but why ? lol

Edited by Sebastiii
0

Share this post


Link to post
Share on other sites

I dont have this issue with 3 diffrent sim cards.

 

I add test support to signal leds ( based on :

Use command on ssh:

wget http://tplink-forum.pl/pub/temp/set_rssi_3g_leds.sh -O /usr/bin/set_rssi_3g_leds.sh
chmod 777 /usr/bin/set_rssi_3g_leds.sh

to simple run use command:

set_rssi_3g_leds.sh start &

to autorun this on startup:

echo "/usr/bin/set_rssi_3g_leds.sh start &" > /etc/rc.local
echo "exit 0" >> /etc/rc.local

 

1

Share this post


Link to post
Share on other sites

Great i will try :)

Thanks.

 

Yep no clue why it happen and it happen randomly so hard to track the cause and log are not really useful too, on Android board it ask for SD card but it seems that on official firmware there is more information but i'm not sure.

Ok it seems that it doesn't start : 

root@lede:/usr/bin# set_rssi_3g_leds.sh start &
root@lede:/usr/bin# -ash: set_rssi_3g_leds.sh: not found

So i have try : 

root@lede:/usr/bin# -ash: ./set_rssi_3g_leds.sh: not found
[1]+  Done(127)                  ./set_rssi_3g_leds.sh start

Still not starting :(

 

Ps : the files is correctly downloaded in /usr/bin and i have verified that it's 777 :) but no luck

Edited by Sebastiii
0

Share this post


Link to post
Share on other sites

Try download again this file. I use wrong "windows" end line char.

1

Share this post


Link to post
Share on other sites

Ok done

redownload file:

wget http://tplink-forum.pl/pub/temp/set_rssi_3g_leds.sh -O /usr/bin/set_rssi_3g_leds.sh
chmod 777 /usr/bin/set_rssi_3g_leds.sh

 

1

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   You have pasted content with formatting.   Remove formatting

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

Loading...