MORTEM

Archer C8 - otoczenie sieciowe i FTP

22 postów w tym temacie

Witam

To mój pierwszy post na tym forum, ponieważ ani infolinia ani maile słane do TP-LINK nic nie dają. Tzn. infolinia nie działa maile sa bez odpowiedzi - gratuluje obsługi klienta !!!

Do rzeczy.

Mam problem z konfiguracją - a może tylko tak mi się wydaje. Chodzi o pliki umieszczone na dwóch dyskach podłączonych do routera i udostępnienie ich w sieci. Tak zewnętrznej, poprzez FTP, jak i wewnętrznej - otoczenie sieciowe.

W zakładce "ustawienia USB" ustawienia urządzeń, widzę dwa dyski:

Zrzut ekranu 2017-01-10 o 10.57.08.png

 

Chce je udostępnić dla otoczenia sieciowego i  przez FTP na zewnątrz i  w tym celu zaznaczam odpowiednie kwadraty

Zrzut ekranu 2017-01-10 o 11.03.52.png

 

I do tej pory wszystko jest OK.

Cały problem zaczyna się, kiedy przez FTP na zewnątrz chcę z obojętnie jakiego dysku udostępnić, TYLKO niektóre pliki. Tak jak poniżej folder z plikami E-book

Zrzut ekranu 2017-01-10 o 11.07.36.png

 

Skutkuje to tym, że otoczenie sieciowe już widzi TYLKO ten jedyny folder z E-bookami i nic poza tym. 

Aktualizowałem router do najnowszej wersji softu z zachowaniem odpowiedniej wersji. Nic to nie dało.

Czy to jest wada tego urządzenia czy ja coś źle robię lub źle rozumuję ta opcję?

Poprzedni mój router 

TL-WR1043ND

działał prawidłowo i opcja udostępniania w sieci plików nie sprawiała problemów.

Pomoże ktoś?

Edytowane przez MORTEM
0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Zgodnie z tym co pisze wyżej, to udostępniłeś tylko jeden folder i mówisz, że tylko on jest udostępniony, no to chyba jest tak jak być powinno? Udostępnij inne to ci się pokażą inne. :D

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Jak udostępnię inne to też się pokażą. Ale jak wtedy wejść do nieudostępnionych lub całego dysku i np coś skasować lub wgrać przez otoczenie sieciowe, skoro widzi TYLKO udostępnione?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

No ja ci z tym problemem nic nie pomogę, bo ja używam głównie routerów z zainstalowanym alternatywnym firmware OpenWRT/LEDE. Nie znam się za bardzo na tym stock'owym oprogramowaniu TP-LINK'a.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Ale nie wydaje się to dziwne, że otoczenie sieciowe zachowuje takie same ustawienia jak FTP? Od tego są przecież pola wyboru. 

Najgorsze jest to, że telefon na infolinię to ściema, a maile są bez odpowiedzi. Nawet jak zareklamuję sprzęt do sprzedawcy (niestety market) to wróci do mnie ze sprawdzeniem, że jest sprawny, bo nikt nie przeczyta albo nie zrozumie opisanego przeze mnie problemu :((

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
13 minut temu, MORTEM napisał:

Ale nie wydaje się to dziwne, że otoczenie sieciowe zachowuje takie same ustawienia jak FTP? Od tego są przecież pola wyboru. 

No ja nie wiem w ogóle jak ma ten mechanizm działać, dlatego właśnie ci nic nie pomogę. Być może jest to takie zachowanie jak obserwujesz, a być może to bug w firmware. Jeśli bug, to wystarczy go zgłosić i powinno poprawić w nowszej wersji.

14 minut temu, MORTEM napisał:

Najgorsze jest to, że telefon na infolinię to ściema, a maile są bez odpowiedzi.

Ja co chwila pisuję z supportem w kilku sprawach i odpowiedzi na moje maile przychodzą, także nie wiem dlaczego u ciebie pozostają bez odpowiedzi. Jesteś pewien, że na prawidłowy mail wysyłasz zapytanie? Może odpowiedzi trafiły do spamu (u ciebie albo u nich)? :D 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Robie to przez ich stronę - wsparcie przez mail, i poprzez dane na ich stronie:

Dla użytkowników w Polsce
Telefon:
+48 (0) 801 080 618 / +48 22 360 63 63 (dla połączeń z telefonów komórkowych)
Opłata:
Zgodnie z taryfą operatora.
E-mail:
support.pl@tp-link.com
Godziny pracy:
Od poniedziałku do piątku w godzinach 9:00-17:00.
 
Wszystko to ściema. Nie ma takich telefonów :)
Niech ktoś się spróbuje zadzwonić na te telefony to się zdziwi.
 
Pop prostu firma krzak - nic dodac nic ująć.
0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

A próbowałeś \\192.168.0.1 w pasku adresu systemowego? Oczywiście adres IP musi pokrywać się z adresem routera.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Tak to dostaję się do samego routera :))

Jasne, że próbowałem. Potem jeszcze \na odpowiedni dysk itd.

Dla mnie to albo uszkodzenie albo bug

 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Cytuj

Ale jak wtedy wejść do nieudostępnionych lub całego dysku i np coś skasować lub wgrać przez otoczenie sieciowe, skoro widzi TYLKO udostępnione?

No ale o to ci właśnie chodziło żeby wejść na pozostałą zawartość dysku i móc ją edytować bez względu na konfigurację FTP-a. Chyba że ty mówisz jeszcze o czymś innym w ferworze twojej niepotrzebnej złości. 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

To jeszcze inaczej. Dyski są widziane przez router jako sda1 i sdb1. To są ich nazwy i można ich używać po backslasu :))

Czyli jak mam udostępnione wszystko, to mogę mapować te dyski, wchodzić na nie, wykonywać wszystkie operacje jaki mi się podobają. Dostęp do nich jest poprzez otoczenie sieciowe, czy to z Windowsa czy OSX'a

\\10.0.10.1\sda1 - działa

\\10.0.10.1\sdb1 - działa

smb://TP-Share działa

ale zaznaczam, że jak jest zaznaczona opcja "udostępnij wszystko"

Ale los chce, że na dyskach tych są też rzeczy, które nie są dostępne dla wszystkich ludzi. Dlatego włączam FTP i selekcjonuję co mam być dostępne dla innych. W tym celu muszę wyłączyć opcję "udostępnij wszystko". Wtedy pokazuje mi się opcja zbudowania listy rzeczy do udostępnienia. Wybieram sobie odpowiednie katalogi i potwierdzam (np. E-book na dysku sdb1). Rzecz prosta. I zaczyna się problem.

\\10.0.10.1\sda1 - nie działa

\\10.0.10.1\sdb1 - nie działa

smb://TP-Share - nie działa

Wszystkie połączenia do tych dysków są już niedostępne. Ale do wybranych plików udostępnionych bez problemu można się dostać:

\\10.0.10.1\sdb1\E-book - działa

smb://TP-Share/E-book - działa

Do żadnych innych zasobów nie mogę się dostać. Musze ponownie udostępnić wszystko i wtedy mogę robić wszystko.

 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Według mnie takie zachowanie jest chyba tym, którego człowiek powinien się spodziewać, tj. albo udostępniasz wszystko, albo tylko wybrane foldery. A ty chcesz udostępnić przykładowo tylko katalog /E-book/ i jednocześnie chcesz mieć dostęp do pozostałych katalogów. No to zdecyduj się w końcu. :D

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

To w ogóle ma jakiś sens? Nie mieć dostępu jako administrator plików? Jak zarządzać plikami bez dostępu do nich?

Napisałem powyżej, że w poprzednim routerze TL-WR1043ND wszystko działa poprawnie. Jest dostęp do otoczenia sieciowego, mimo, że przez FTP mogę udostępnić co chcę.

 
0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Czy w panelu masz jakieś opcje kontroli uprawnień, by nadać konkretnemu użytkownikowi uprawnienia do wglądu do danego katalogu? Z tego co ja widzę na tych obrazkach, to nie ma. Więc jak chcesz by router rozróżnił ci użytkowników, którzy uzyskują dostęp do zasobów? Moim zdaniem to oprogramowanie potrafi tylko dwie rzeczy: udostępnić wybrane katalogi lub udostępnić całe nośniki i tyle w sumie. Choć tak jak pisałem wcześniej, ja nigdy z tego nie korzystałem i nie wiem jak to powinno działać w praktyce.

 

1 godzinę temu, MORTEM napisał:

Napisałem powyżej, że w poprzednim routerze TL-WR1043ND wszystko działa poprawnie.

Być może na tym poprzednim routerze był bug i teraz poprawili? :D

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

:D zaczynasz poprawiać mi humor.

Choć masz rację, w poprzednim routerze oprócz konta administratora, można było przypisać gościa Zrzut ekranu 2016-12-26 o 14.08.58.png

 

W Archer C8 mozna przypisać do uprawnień userów którzy będa się logowali na takie same dane jak do logowania routera - co jest niebezpieczne, jako zdefiniowany user:

Zrzut ekranu 2017-01-11 o 16.00.15.png

 

lub wyłączyć uwierzytelnieni w ogóle:

Zrzut ekranu 2017-01-11 o 16.00.35.png

 

Może i macie rację. Przyzwyczajając się do działania jednego urządzenia, wymagam aby inne działało tak samo. Choć w/g mnie nie jest to logiczne.

 

 

 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

 

sharing.jpg

Według mnie zasoby możesz konfigurować pod odpowiednie konto i według nich zarządzać zasobami które mają być widoczne w całej sieci a które tylko po wpisaniu loginu i hasła.

Edytowane przez jimasek
0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Niestety nie, choć pewnie tak powinno być. Zrobiłem tak jak pokazałeś to powyżej:

Zrzut ekranu 2017-01-11 o 18.37.45.png

Skutkuje to tym:

Zrzut ekranu 2017-01-11 o 18.38.44.png

Czyli brakiem możliwości wejścia na jakikolwiek z dwóch dysków.

Natomiast udostępniony folder z E-bookami - oczywiście jest dostępny. Ale TYLKO on.

Zrzut ekranu 2017-01-11 o 18.39.21.png

 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Może trochę to skomplinkowane ale zawsze możesz udostępnić dysk dwa razy. tzn jeden zasób udostępniasz cały / z hasłem i drugi raz udostępniasz już tylko wybrany folder ( z dostępem dla gości - bez hasła)

Po wejściu na //192.168.0.1/ zobaczysz dwa foldery:

/ oraz /folder

po wejściu na / zapyta o hasło

po wejściu na /folder nie pyta o nic

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Zrobiłeś to bez uwierzytelnienia a pytanie czy system nie pamięta konfiguracji z hasłem? No i dlatego nie pozwala na oglądanie zawartości?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Właśnie idę drogą mr. Heinz. Tyle, że już widzę, że żeby udostępnić cały dysk musze utworzyć jeden główny folder, lub podzielic dysk na udostępniane i nieudostępniane. Powiadomię o wynikach soon.

 

Wielki szacun mr.Heinz !!!! to działa :D

Jednak moja logika dobrze zawiodła. Sam odbierałem sobie prawa, nie udostępniając całego dysku. W poprzednim routerze logika udostępniania była a priori  ustawiana na otoczenie sieciowe. To mnie zapędziło w kozi róg.

 

Dziękuję wszystkim, którzy znosili moje wypociny i pomagali !!!!! Dzięki Takim ludziom warto pisać i pytać !!!!

 

Jeszcze ostatnie pytanie. Czu jest jakaś zależność zaznaczania tych pól? Czy zaznaczę czy nie nic się nie zmienia.

 

 

Zrzut ekranu 2017-01-11 o 19.37.12.png

Edytowane przez MORTEM
0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Gość
Komentujesz jako gość. Jeśli posiadasz konto, zaloguj się.
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Only 75 emoticons maximum are allowed.

×   Odnośnik został osadzony automatycznie.   Wyświetlaj jako odnośnik

×   Your previous content has been restored.   Clear editor

Ładowanie